Author Topic: Can't install BitMessage because of wrapper error.  (Read 374 times)

Dani

  • Newbie
  • *
  • Posts: 25
    • View Profile
Can't install BitMessage because of wrapper error.
« on: March 12, 2014, 02:14:24 pm »
I follow the instruction at
https://bitmessage.org/wiki/Compiling_instructions

When I run the first line
git clone https://github.com/Bitmessage/PyBitmessage $HOME/PyBitmessage
I get
uwtwrapper uwt wrapper ERROR: /usr/bin/git.whonix-orig does not exist.


I searched and no one seems to have had this problem already. Because of the name of the file, I believe it's whonix specific?

I'm with just installed whonix 8

Patrick

  • a maintainer of Whonix
  • Administrator
  • *****
  • Posts: 2985
  • (adrelanos)
    • View Profile
    • Patrick Schleizer – Profile Page
Re: Can't install BitMessage because of wrapper error.
« Reply #1 on: March 12, 2014, 03:43:07 pm »
This is Whonix specific indeed. In next version there will be a more helpful error message, that shows the same output as "command-not-found git".

Long story short, you can use git by installing git.

Code: [Select]
sudo apt-get update
sudo apt-get install git
HOT: How to Ask Smart Questions | How to Report Bugs Effectively
Impressum | Datenschutzerklärung | Haftungsausschluss
If Whonix (g+) is useful to you, please consider a reoccurring donation so I (e-mail) (gpg) (g+) can work full time on Whonix.
Need more attention? Get Professional Support!

Dani

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: Can't install BitMessage because of wrapper error.
« Reply #2 on: March 12, 2014, 08:08:28 pm »
It worked, thank you!


 

Legal

Impressum Datenschutz Haftungsausschluss Contact

Links

Homepage Blog Issues Github

Misc

Contribute Donate Investors Free Support Professional Support