[Whonix-devel] codecrypt impossible dependencies

bancfc at openmailbox.org bancfc at openmailbox.org
Wed Sep 28 16:40:23 CEST 2016

   Package: codecrypt
   Version: 1.7.5-1

   Dear maintainer, I am trying to install codecrypt from a pinned sid 
repo on Jessie.

   After including other dependency packages as well, apt has run into a 
unresolvable dependency requirement. libstdc++6 insists on libkolabxml1 
1.1.0-3 while the newest version available in sid is 1.0.2-2

   AFAICT this dependency conflict is a blocker even if the user is 
running unstable.

user at host:~$ sudo apt-get -t unstable install codecrypt libkolab0 
libcrypto++6 libstdc++6 libkolabxml1
Reading package lists... Done
Building dependency tree
Reading state information... Done
libkolab0 is already the newest version.
libkolab0 set to manually installed.
libkolabxml1 is already the newest version.
libkolabxml1 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libstdc++6 : Breaks: libkolabxml1 (<= 1.1.0-3) but 1.0.2-2 is to be 
E: Unable to correct problems, you have held broken packages.

More information about the Whonix-devel mailing list